Modul-Workflow: Level 1 (Tutorial) Bis DB 39.5.14

stop Achtung
  • Dieses Tutorial gilt für PLANTA Datenbank-Versionen bis 39.5.14.
  • Links zu den Beschreibungen weiterer Versionen entnehmen Sie bitte der Tabelle:
>= DB 39.5.14 zum Tutorial

info Informationen

  • Der nachfolgende Workflow vermittelt das Basiswissen zum PLANTA-eigenen Konfigurationstool (PLANTA-Customizer), mit dem die Anwenderoberfläche (PLANTA Project) erstellt und angepasst werden kann.
  • Fachliches Basiswissen zu PLANTA Project vermittelt der Projekt-Workflow.

stop Voraussetzung

  • Den Inhalt folgender Topics zu kennen und zu verstehen, gilt als Grundvoraussetzung für die Ausführung dieses Workflows:
    • Erste Schritte - Einstieg in das PLANTA-Programm und Beschreibung der Oberfläche
    • Feldtypen - Beschreibung der wichtigsten Datenfeldtypen und deren Bedienung
    • Programmbedienung - Markieren, Kopieren, Speichern, Löschen, Einfügen sowie Ein- und Ausblenden von Daten, Bedienung des Kontextmenüs

warning Hinweis

  • Die verwendeten Screenshots dienen der exemplarischen Darstellung und können vom tatsächlichen Layout im Programm abweichen.

Allgemeine Customizing-Informationen

info Datenstruktur

  • PLANTA Project-Datensätze werden in Datenfeldern der Module bearbeitet.
  • Ein Modul besteht aus Datenbereichen.
  • Ein Datenbereich
    • entspricht einer Datentabelle.
    • besteht aus Datenfeldern.
  • Ein Datenfeld entspricht einem Dataitem.
  • Ein Dataitem gehört zu einer Datentabelle.
  • Die Dataitems einer Datentabelle bilden den Datensatz.

note Moduldetails

  • Einem Modul
    • muss mindestens ein Datenbereich zugeordnet werden.
    • können beliebig viele Datenbereiche zugeordnet werden.
  • Ein Datenbereich
    • kann mehrfach verwendet, d.h., mehreren Modulen zugeordnet werden.
    • muss mindestens ein Dataitem als Datenfeld zugeordnet bekommen.
    • kann beliebig viele Dataitems als Datenfelder zugeordnet bekommen.

application Widerspiegelung Datenbank im Modul

Customizer.png

Modul anlegen

target-blue Ziel

  • Anlegen eines einfachen Moduls

more Vorgehensweise

  • Login mit P20.
  • Im Benutzermenü Customizer --> Modul-Customizer --> Module aufrufen.
    • Der Cursor steht automatisch im Datenfeld MOD.
  • Im Feld Modul einen Modultitel (z.B. Testmodul) eingeben.
  • ENTER
    • Es wird automatisch eine neue Modulidentnummer vergeben.
  • Speichern.
  • Ergebnis:
ModulAnlegen.png
tip Tipp: Anlegen eines Moduls durch Kopieren
  • Alternativ kann ein Modul auch durch Kopieren eines bestehenden Moduls angelegt werden. Dabei wird eine 1:1-Kopie des Ausgangsmoduls erstellt.
  • Vorgehensweise
    • Identnummer des zu kopierenden Moduls in das Datenfeld Kopieren von eingeben.
    • Nach Betätigen der ENTER-Taste wird im Datenfeld MOD eine neue Modulidentnummer vergeben.
    • Im Datenfeld Modul den neuen Modultitel eingeben.
    • Speichern.
      • Beim Speichern werden alle Parameter des Quellmoduls sowie seine Unterobjekte (Untermodule, Datenbereiche, Modulvarianten) in das neue Modul kopiert.

Datenbereich anlegen

target-blue Ziel

  • Für das neu erstellte Modul Testmodul einen Datenbereich anlegen.

more Vorgehensweise

  • Im Modul Module Klick mit der rechten Maustaste auf die Modulnummer.
  • Einfügen --> Datenbereichszuordnung aus dem Kontextmenü auswählen.
    • Ein leerer Datenbereichs-Datensatz wird eingefügt.
  • Klick auf den Link Keine Bezeichnung im Feld Datenbereich
  • Im Modul Datenbereiche Klick auf den Link 000 neben dem Feld Datentabelle.
DBAnlegen1.png

  • Das Modul Data Dictionary wird aufgerufen.
  • Für die Datentabelle Projekt in das Datenfeld DT den Wert 461 eintragen oder die Datentabelle 461 aus der Listbox auswählen.
    • Es werden alle Dataitems der Datentabelle 461 Projekt angezeigt.
      • tip Durch Klick auf die Spaltenüberschrift kann man nach der jeweiligen Spalte sortieren.
  • Via Drag&Drop-Kopieren die Identnummer des Dataitems Projekt-ID in das Datenfeld DDI im Modul Datenbereiche kopieren oder diese manuell eintragen.
    • Es wird automatisch eine neue Datenbereichs-Identnummer generiert.
DBAnlegen2.png

  • Speichern.

Datenfelder zu Datenbereich zuordnen

target-blue Ziel

  • Dem neu erstellten Datenbereich sollen Datenfelder zugeordnet werden.

more Vorgehensweise

  • Über rechte Maustaste Einfügen --> Datenfeld im Modul Datenbereiche einen untergeordneten Datensatz für die Datenfelder einfügen.
  • Mit Drag&Drop-Kopieren die Identnummer des Dataitems Projekt-ID auf das eingefügte Datenfeld kopieren.
  • Durch Klick auf das Dataitem Projekt-ID dieses aktivieren und über die rechte Maustaste oder durch Klick auf den Button Einfügen in der Symbolleiste sechs weitere Datenfelder einfügen.
  • Mit Drag&Drop-Kopieren die Identnummern folgender Dataitems aus der DT461 Projekt im Modul Data Dictionary ins Feld DI kopieren oder über die Listbox im Feld DI auswählen:
    • 000690 Projektbezeichnung
    • 023220 Art
    • 001020 Wunsch-Ende
    • 001042 Status
    • 001014 Code
    • 001062 Manager
    • warning Die Listbox zeigt alle Dataitems aus der Datentabelle, aus der auch das DDI des Datenbereichs stammt.
  • Speichern.
DFZuordnen.png
tip Tipp: Anlegen eines Datenbereichs über den Kontextmenü-Befehl Dataitems in Datenbereich übernehmen.
  • Im Modul Module Klick auf den Link 000 im Feld DT.
  • Die Listbox im Feld DT enthält alle Datentabellen der PLANTA-Datenbank.
  • Für die Datentabelle Projekt in das Datenfeld DT den Wert 461 eintragen oder die Datentabelle 461 aus der Listbox auswählen.
    • Es werden alle Dataitems der DT461 Projekt angezeigt.
    • Durch Klick auf die Spaltenüberschrift kann nach der jeweiligen Spalte sortiert werden.
  • Die Dataitems, die in den Datenbereich übernommen werden sollen, markieren.
  • Mit der rechten Maustaste auf eines der Dataitems klicken und den Kontextmenü-Befehl Dataitems in Datenbereich übernehmen auswählen.
    • Dabei werden nur die markierten Dataitems übertragen.
  • Das Modul Datenbereich auswählen wird automatisch geöffnet.
    • Ein neuer Datenbereich wird automatisch angelegt.
    • Sind noch Instanzen des Moduls Datenbereiche offen, werden die Datenbereiche ausgelesen und automatisch eingefügt.
      • Sollen die Dataitems einem anderen, bereits existierenden, Datenbereich hinzugefügt werden, kann über F4 ein neuer Datensatz in Fenster 1 angelegt werden.
      • Danach in das Feld DA die ID des gewünschten Datenbereichs eintragen.
    • Der Wert im Feld DDI wird automatisch auf das Ident von DI der entsprechenden Datentabelle gesetzt.
    • Die vorher ausgewählten Dataitems werden im Fenster 2 angezeigt.
    • Die Schaltfläche Dataitem in Bereich übernehmen betätigen.
      • Die Dataitems werden in den Datenbereich übernommen.
  • Speichern.

Datenbereich zu Modul zuordnen

target-blue Ziel

  • Den neu angelegten Datenbereich dem Modul Testmodul zuordnen.

more Vorgehensweise

  • Mit Drag&Drop-Kopieren die Identnummer des gerade angelegten Datenbereichs in das Datenfeld DA im Modul Module kopieren.
  • Die Position des Datenbereichs innerhalb des Moduls durch manuelle Eingabe des Wertes 1 im Feld Pos. bestimmen.
    • Wird keine Position für den Datenbereich gesetzt und das Modul gestartet, erscheint die Meldung: Modul-Datenbereichs-Zuordnung nicht gefunden.
  • Speichern.
DBZuordnen.png

stop Achtung

  • Ein Datenbereich darf nicht einem Modul doppelt zugeordnet werden.
    • Die Missachtung dieser Regel kann zu Problemen führen.

more Modul testen

  • Im Modul Module die Schaltfläche ModulStarten.png Aktuelles Modul starten links neben der Modulnummer betätigen.
    • Das Modul wird aufgerufen, allerdings werden keine Daten angezeigt. Um Daten anzuzeigen:
      • Klick auf den Button Filterkriterien in der Symbolleiste
      • Klick auf die Schaltfläche Filtern
        • Es werden alle Projekte, Vorhaben, Ideen und Requests, die in der Datenbank existieren, mit den zugeordneten Datenfeldern angezeigt.
Testmodul.png
warning Hinweis
  • Das neu erstellte Modul Testmodul wird beim Aufruf als Untermodul im Customizing-Panel angezeigt. Damit das Modul in einem eigenen Panel geöffnet wird, den Parameter Hauptmodul aktivieren.

index Siehe auch: Customizing von Panels

Makro erstellen

target-blue Ziel
  • Beim Aufrufen des Moduls soll automatisch nach allen Projekten gesucht werden.

more Vorgehensweise

  • Im Modul Module Klick auf die Schaltfläche PythonMakro.png Python-Makrobearbeitung aufrufen.
    • Der Editor wird aufgerufen und gleichzeitig wird das nachfolgende Makrotemplate einkopiert.
      • warning Achtung: In der globalen Einstellung py_editor muss der richtige Editor hinterlegt worden sein, andernfalls erscheinen beim Betätigen des Buttons folgende Fehlermeldungen:
        • Bitte hinterlegen sie einen Editor! oder
        • Error executing python script: Das System kann die angegebene Datei nicht finden.
##MacroTemplate

mod_obj = ppms.get_target_module()

def on_load():
    pass

def on_initial_focus():
    mod_obj.menu(11)

def on_focus():
    pass

def on_reset():
    on_initial_focus()

def on_before_mv_switch(old_mv, new_mv):
    pass

def on_after_mv_switch(old_mv, new_mv):
    pass

  • Die erste Zeile (#MacroTemplate) löschen.
  • Das Template enthält in der Python-Funktion on_initial_focus den Befehl mod_obj.menu(11). Dieser Befehl referenziert den Menüpunkt 11 Einfügen, d.h. beim Modulaufruf wird ein leerer Projekt-Datensatz eingefügt, in dem eine Projektnummer eingegeben werden kann.
  • Da beim Aufrufen des Moduls die Funktion Filtern (Menüpunkt 12) statt der Funktion Einfügen ausgeführt werden soll, muss im Makro mod_obj.menu(11) durch mod_obj.menu(12) ersetzt werden.
  • Mit STRG + S oder durch Klick auf den Button Speichern im Editor speichern.

more Modul testen

  • Beim nächsten Aufruf des Moduls werden automatisch alle Projekte, Vorhaben, Ideen und Requests gesucht und angezeigt.

warning Hinweise

  • Die Python-Makros können auch im Modul Pythonmakros bearbeitet werden, dieses wird über die Schaltfläche MakroBearbeitung.png Makrobearbeitung aufrufen aufgerufen.
  • Hat das Modul sowohl ein Pythonmakro als auch ein konventionelles Makro, wirkt nur das Pythonmakro.

index Siehe auch: Python-API, IDs der Menüpunkte

Datenbereich bearbeiten

info Informationen

  • Die Bearbeitung der Datenbereiche erfolgt im Modul Datenbereiche.
  • Das Modul Datenbereiche lässt sich auf folgende Weisen aufrufen:
    • Klick auf den Link im Datenfeld Datenbereich des gewünschten Datenbereichs
    • Klick mit der rechten Maus auf die gewünschte Datenbereichszuordnung und Auswahl des Befehls Datenbereich bearbeiten.
    • Im Benutzermenü das Modul Datenbereiche öffnen und die gewünschte Datenbereichsnummer im Feld DA eingeben.

Filterkriterien einstellen

target-blue Ziel
  • Beim Aufruf des Moduls Testmodul sollen nur noch Projekte angezeigt werden (Projekt-Art=0)

more Vorgehensweise

  • Den Datenbereich Projekt aufrufen.
  • Für das Datenfeld Art im Parameter Filtern von den Wert 0 für Projekt eintragen.
DBBearbeiten1.png

  • Speichern.

more Modul testen

  • Nach Neustart des Moduls Testmodul erscheinen nur noch Projekte.
DBBearbeiten2.png

index Siehe auch: Filtern

Sortierkriterien einstellen

target-blue Ziel
  • Projekte nach der Projektbezeichnung sortieren.

more Vorgehensweise

  • Den Datenbereich Projekt aufrufen.
  • Für das Datenfeld Projektbezeichnung im Parameter Sortierreihenfolge den Wert 1 eingeben.
DBBearbeiten3.png

  • Speichern.

more Modul testen

  • Nach Neustart des Moduls Testmodul sind die Projekte nun aufsteigend nach der Projektbezeichnung sortiert.
DBBearbeiten4.png

tip Tipp

Rahmen customizen

target-blue Ziel
  • Jeder Datensatz des Datenbereichs Projekt soll umrahmt werden.

more Vorgehensweise

  • Den Datenbereich Projekt aufrufen.
  • Im Datenfeld Symbol Rahmen F1 das gewünschte Rahmensymbol, z.B. 001937 hinterlegen.
  • Speichern.
RahmenCU.png

more Modul testen

  • Nach Neustart wird ein blauer Rahmen um jeden Datensatz des Datenbereichs Projekt angezeigt.
RahmenCU1.png

Datenbereich als Maske gestalten

target-blue Ziel
  • Im Modul Testmodul sollen die Projektdaten nicht mehr tabellarisch, sondern in einer Maske angezeigt werden.
info Information
  • Um die folgenden Schritte zu vereinfachen, wird nur nach einem Projekt (z.B. Projekt 4811) gefiltert.
    • Dafür im Datenbereich Projekt für das Datenfeld Projekt-ID im Feld Filtern von die Projekt-ID, hier 4811, eintragen und speichern.
MaskeGestalten1.png

more Vorgehensweise

  • Das Modul Testmodul durch Klick auf den Button ModulStarten.png Aktuelles Modul starten aufrufen.
  • Den Customizing-Modus über Maskeneditor --> Customizing-Modus aktivieren.
  • Klick in den Datenbereich, der zur Maske werden soll.
  • Durch Auswählen der rechten Maustaste Maske wird der Datenbereich zur Maske.
    • Dabei werden automatisch für alle Felder X/Y-Positionen entsprechend des horizontalen Autolayouts gesetzt.
    • warning In Masken bestimmt das Symbol im Datenfeld Symbol Rahmen F1 nicht nur den Rahmen, sondern auch die Hintergrundfarbe des Datenbereichs.
MaskeGestalten2.png

MaskeGestalten3.png

MaskeGestalten4.png

warning Hinweise

  • Die Tabreihenfolge der Felder im Modul hängt von der Reihenfolge der Datenfeld-Datensätze im Modul Datenbereiche ab.
  • Die X/Y-Positionen sowie die Breite und Höhe der Datenfelder und Überschriften können auch manuell im Modul Datenbereiche bearbeitet werden, die entsprechenden Parameter befinden sich in der Modulvariante Layout.

Datenfeldverhalten definieren

Checkboxen

target-blue Ziel

  • Im Modul Testmodul ein Checkbox-Feld mit Eingabemöglichkeit hinzufügen

more Vorgehensweise

  • Den Datenbereich Projekt aufrufen.
  • Ein neues Dataitem (mit dem Spaltentyp= Ja/Nein ) aus der DT461 Projekt auswählen und dem Datenbereich hinzufügen, z.B. 000141 Gesperrt.
    • Im Feld DF-Verhalten wird automatisch i2 eingetragen, was bedeutet, dass die Checkbox eine Eingabe-Checkbox ist.
      • warning Soll die Checkbox output sein, aus der Listbox o2 auswählen.
  • Die X/Y-Positionen (Y-Pos. Ü, X-Pos. Ü, Y-Pos. F, X-Pos. F) und die Datenfeld-Breiten und -Höhen (DF-Höhe, DF-Breite) festlegen.
  • Speichern.
Checkbox.png

warning Hinweis

  • Dataitems mit Spaltentyp = Ja/Nein sind automatisch Checkboxen.

more Modul testen

  • Nach Neustart des Moduls ist das Checkbox-Feld Gesperrt in der Modulmaske sichtbar.
Checkbox1.png

Ampeln

target-blue Ziel

  • Im Modul Testmodul soll das Datenfeld Code in Abhängigkeit vom Projektcode in einer anderen Farbe dargestellt werden (= eine Ampelfunktion erhalten).

more Vorgehensweise

  • Den Datenbereich Projekt aufrufen.
  • Für das Datenfeld Code im Parameter Ampel-DI
    • ein Ampel-DI aus der Listbox auswählen, z.B. 000236
Ampel.png
AmpelCode.png
    • oder ein Ampel-DI zuordnen, falls ein individuelles gecustomized wurde.
  • Speichern.

warning Hinweise

  • Das Datenfeld, dem die Ampel zugeordnet wird, und das Ampel-DI selbst müssen aus der gleichen Datentabelle stammen. Darauf muss sowohl beim Zuordnen eines vorhandenen Ampel-DIs als auch beim Customizen eines neuen Ampel-DIs geachtet werden.
  • Ampeln können allen normalen (auch background-) oder projizierten Datenfeldern zugeordnet werden.
  • Ampeln können nicht Balken zugeordnet werden, da diese bereits in ihrer eigenen Konstruktion eine Art Ampelfunktion enthalten. Auf Balkenhilfsfeldern dagegen können Ampeln verwendet werden.
  • Sollen alle Datenfelder im Datenbereich (d.h. im Modul der ganze Datensatz) farblich hervorgehoben werden, muss die Ampel auf allen Datenfeldern hinterlegt werden.

more Modul testen

  • Nach Neustart des Moduls ist die Ampelfunktion auf dem Datenfeld Code sichtbar.
Ampel1.png

index Siehe auch: Ampelfelder, Customizing von Ampeln

Listbox

target-blue Ziel

  • Im Modul Testmodul soll dem Feld Status eine Listbox zugeordnet werden

more Vorgehensweise

  • Den Datenbereich Projekt aufrufen.
  • Für das Datenfeld Status im Parameter LBMOD die ID der Listbox (z.B: 000644 LB: Projektstatus) eintragen.
  • Im Parameter DF-Verhalten den Wert le eintragen bzw. aus der Listbox auswählen.
    • Durch die Auswahl der Werte le oder li wird festgelegt, ob es eine implizite oder eine explizite Listbox ist.
    • Nur wenn der Parameter DF-Verhalten mit einem von oben genannten Werten gefüllt ist, wird die Listbox im Datenfeld angezeigt.
  • Speichern.
ListboxZuordnen.png

more Modul testen

  • Nach Neustart des Moduls ist die Listbox in dem gewünschten Datenfeld sichtbar und kann verwendet werden.
LBZuordnenErgebnis.png

index Siehe auch: Listboxen, Customizing von Listboxen

Aktionen definieren

info Informationen
  • Über Aktionen können u.A. Makros bzw. Module aufgerufen werden.
  • Nachfolgend werden zwei Aktionen beschrieben.

index Siehe auch: Customizen von Aktionen

Schaltflächen

target-blue Ziele

  • Im Modul Testmodul soll eine Schaltfläche hinzugefügt werden.
  • Über die Schaltfläche soll ein Modul, z.B. das Modul Dokumente, aufgerufen werden.

more Vorgehensweise

  • Den Datenbereich Projekt aufrufen.
  • Einen neuen Datensatz einfügen und das Dataitem 004336 Button/IronPython zuordnen.
    • Im Parameter Aktions-ID die Modulnummer des Moduls Dokumente (0099IP) eintragen.
    • Im Parameter DF-Verhalten mit dem Wert c1 auswählen.
SFEinfuegen.png

  • In die Modulvariante Layout wechseln.
  • Mit den Parametern DF-Höhe und DF-Breite die Größe der Schaltfläche und mit den Parametern X-Pos. F und Y-Pos. F die Position der Schaltfläche im Modul festlegen.
  • Speichern.
SFEinfuegen1.png

more Modul testen

  • Nach Neustart des Moduls ist die Schaltfläche sichtbar und kann verwendet werden.
SFEinfuegen2.png

Links

target-blue Ziele

  • Im Modul Testmodul soll das Datenfeld Projekt-ID als Link definiert und dargestellt werden.
  • Über den Link soll ein Modul, z.B. Dashboard, in dem die Projektdaten angezeigt werden, aufgerufen werden.

more Vorgehensweise

  • Den Datenbereich Projekt aufrufen.
  • Das Datenfeld Projekt-ID als Link definieren. Hierfür
    • im Parameter DF-Verhalten den Wert e1 auswählen und
    • im Parameter Aktions-ID die Nummer eines Makros z.B. 009A0W Projekt aufrufen eintragen. Das Modul wird über das Makro aufgerufen. Mit dem Makro wird definiert, welche Daten im Modul angezeigt werden sollen.
      • warning Wird im Parameter Aktions-ID die ID des aufzurufenden Moduls (hier: 0099JT) eingetragen, wird zwar das Modul aufgerufen, aber es werden keine Daten angezeigt.
LinkDefinieren.png

  • Das Datenfeld Projekt-ID als Link darstellen.
    • Hierfür in die Modulvariante Layout wechseln und im Parameter Symbol-ID den Wert 001807 eintragen.
LinkDefinieren1.png

  • Zurück in die Basis-Modulvariante wechseln.
  • Im Parameter Tooltip den Text eintragen, der beim Mouseover über den Link als Tooltip erscheinen soll.
  • Speichern.
LinkDefinieren2.png

more Modul testen

  • Nach Neustart des Moduls ist das Datenfeld Projekt-ID als Link definiert und dargestellt.
LinkDefinieren3.png

  • Klick auf den Link Projekt aufrufen
  • Das Modul Dashboard wird aufgerufen und die Projektdaten werden angezeigt.
LinkDefinieren4.png

index Siehe auch: Link-Datenfelder

Individuelle Datenfeldüberschriften

target-blue Ziel

  • Im Modul Testmodul soll das Feld Status eine andere Bezeichnung erhalten.

info Informationen

  • Es ist möglich, pro Datenbereich individuelle Bezeichnungen für Datenfelder zu verwenden.
  • Sie werden in allen Modulen angezeigt, in denen der entsprechende Datenbereich verwendet wird.

more Vorgehensweise

  • Den Datenbereich Projekt aufrufen.
  • Für das Datenfeld Status eine neue Überschrift (z.B. Projektstatus) im Parameter DF-Überschrift eintragen.
  • Speichern.
DFIndividuell.png

more Modul testen

  • Das Modul Testmodul neu starten.
  • Anstatt Status wird die Bezeichnung Projektstatus angezeigt.
DFIndividuell1.png

OLE-Objekte einbinden

Konstante OLE-Objekte einbinden

target-blue Ziel

  • Im Modul Testmodul soll auf der Schaltfläche ein OLE-Objekt angezeigt werden.

more Vorgehensweise

  • Das gewünschte OLE-Objekt im Modul OLEs aussuchen und die ID notieren.
  • Den Datenbereich Projekt aufrufen.
  • Im Datenbereich Projekt dem DI004336 Button/IronPython im Parameter Standardwert das Präfix DBOLE und die ID des ausgesuchten OLE-Objektes in Klammern eintragen, z.B.: DBOLE(000685).
  • Speichern.
OLEEinbinden.png

more Modul testen

  • Nach Neustart des Moduls wird das ausgewählte OLE-Objekt auf der Schaltfläche angezeigt.
OLEEinbinden1.png

index Siehe auch: OLE-Objekte

Exkurs: Variable OLE-Objekte einbinden

target-blue Ziel

  • In einem bestimmten Feld sollen in Abhängigkeit von Feld-Werten unterschiedliche OLE-Objekte erscheinen.

more Vorgehensweise

Weiteren Datenbereich einfügen

target-blue Ziel
  • Dem Modul Testmodul soll ein weiterer Datenbereich hinzugefügt werden, in dem die Vorgänge angezeigt werden.

more Vorgehensweise

  • Einen neuen Datenbereich mit folgenden Datenfeldern aus DT463 Vorgang anlegen:
    • DDI = 001098 Vorgangs-ID
    • Datenfelder:
      • 001098 Vorgangs-ID
      • 000807 Vorgangsbezeichnung
      • 001134 Aufwand-Soll
      • 001135 Aufwand-Ist
      • 001136 Aufwand-Rest
  • Speichern.
DBNeu.png

  • Das Modul Module aufrufen und die Identnummer des Moduls Testmodul eingeben.
  • Einen leeren Datensatz für den neuen Datenbereich einfügen durch:
    • Klick auf den vorhandenen Datenbereich und Betätigen des Buttons Einfügen in der Symbolleiste
    • oder Klick mit der rechten Maustaste auf den vorhandenen Datenbereich und Auswahl Einfügen --> Datenbereichszuordnung.
  • Die Nummer des neu angelegten Datenbereichs im Feld DA eingeben.
  • Im Parameter Pos. den Wert 2 eintragen.
  • Speichern.
DBNeu1.png

warning Hinweise

  • Wird das Modul jetzt aufgerufen, wird im Projektbereich das Projekt 4811 und im Vorgangsbereich die Vorgänge aller Projekte angezeigt .
  • Damit im Vorgangsbereich nur Vorgänge des Projekts 4811 angezeigt werden, müssen die Datenbereiche strukturiert werden.

Datenbereiche strukturieren

target-blue Ziel
  • Anzeigen der Daten des Datenbereichs Vorgang unter dem zugehörigen Projekt

more Vorgehensweise

  • Die beiden Bereiche liegen jetzt auf der gleichen Ebene. Sie sollen so strukturiert werden, dass der neue Datenbereich Vorgang dem Datenbereich Projekt untergeordnet ist.
    • Hierzu den Datenbereich Vorgang mit SHIFT + Ziehen mit der linken Maustaste auf den Datenbereich Projekt ziehen und loslassen. Somit wird der Bereich Vorgang dem Bereich Projekt untergeordnet. Bei dem Datenbereich Vorgang wird im Feld Oberbereich der Wert 1 automatisch eingetragen.
  • Speichern.
DBStrukturieren.png

warning Hinweis

  • Die Datenbereiche können auch durch manuelles Befüllen des Parameters Oberbereich strukturiert werden:
    • Hierfür im Parameter Oberbereich des Datenbereichs, der untergeordnet werden soll, die Pos. des Datenbereichs, der übergeordnet werden soll, eintragen.

more Modul testen

  • Das Modul Testmodul neu starten.
  • Unterhalb der Projektmaske wird der Datenbereich Vorgang angezeigt.
  • Daten, die im Datenbereich Vorgang angezeigt werden, gehören zu dem jeweiligen Projekt.
DBStrukturieren1.png

warning Hinweise

  • Datenbereiche können nur dann sinnvoll strukturiert werden, wenn sie relational miteinander verbunden sind. Entweder über eine Relation in der Datentabelle oder über die Datenfelder Relation zu rekursivem Unterbereich oder Relation zu Oberbereich.
  • Werden die Datenbereiche falsch strukturiert (also die Parameter Pos. und Oberbereich falsch gesetzt), erscheint i.d.R. bei Aufruf des Moduls folgende Meldung: MCU: Suchpfad konnte nicht erzeugt werden.
  • Wird ein Modul technisch richtig, jedoch anwendungslogisch falsch konstruiert, liefert das Modul falsche Daten.
    • application Beispiel: Wird für den Vorgangs-Datenbereich der Parameter Oberbereich nicht gefüllt, werden unter dem Projekt-Datenbereich auf gleicher Ebene alle Vorgänge (aller Projekte) angezeigt.

Baumdarstellung anzeigen

target-blue Ziel

  • Im Modul Testmodul die Vorgänge des Projekts als Baumstruktur anzeigen lassen.
    • Durch die Baumstruktur werden die Vorgänge eingerückt unter dem Projekt angezeigt. Dadurch wird die Hierarchie (Die Vorgänge sind dem Projekt untergeordnet) sichtbar.
    • Zusätzlich erscheint im Projekt-Datenbereich das +/--Symbol, mit dem die Vorgänge ein- bzw. ausgeblendet werden können.

more Vorgehensweise

  • Im Modul Module auf der Modul-Datenbereichszuordnungs-Ebene für die Datenbereiche Vorgang und Projekt im Feld Baum auswählen, in welchem Fenster das +/--Zeichen erscheinen soll (hier: 1).
  • Den Parameter Baumdarstellung aktivieren.
    • Soll die Gitterlinie angezeigt werden, muss zusätzlich der Parameter Gitterlinie aktiviert werden.
  • Speichern.
BaumdarstellungAnzeigen.png

more Modul testen

  • Das Modul Testmodul neu starten.
  • Im Projekt-Datenbereich erscheint das +/--Symbol, mit dem die Vorgänge ein- bzw. ausgeblendet werden können.
  • Die Vorgänge des Projekts werden unter dem Projekt eingerückt dargestellt.
  • Die Gitterlinie wird angezeigt.
BaumdarstellungAnzeigen1.png
BaumdarstellungAnzeigen2.png

warning Hinweis

  • Baumdarstellungen für Datenbereiche mit aktiviertem Parameter Neben Oberbereich und über mehrere Fenster hinweg müssen beim Customizing vermieden werden, da diese zu falschen Darstellungen führen.

Datenfelder auf mehrere Fenster verteilen

target-blue Ziel
  • Im Modul Testmodul sollen Vorgangs-Aufwands-Datenfelder in Fenster 2 angezeigt werden.

more Vorgehensweise

  • Den Datenbereich Vorgang aufrufen.
  • Für die Datenfelder Aufwand-Soll, Aufwand-Ist und Aufwand-Rest im Feld Fenster den Wert 2 auswählen.
  • Speichern.
DFVerteilen.png

  • Das Modul Datenbereiche schließen.
  • Im Modul Module die Modulvariante Parameter auswählen.
  • Im Feld Breite F2 eine Breite für Fenster 2 eingeben, z.B. 800.
  • Speichern.
DFVerteilen1.png

warning Hinweis

  • Im Anwendungs-Modul kann die Breite des Fensters nachträglich optimiert und mit dem Menüpunkt Modul-CU speichern gespeichert werden.

more Modul testen

  • Das Modul Testmodul neu starten.
  • Die Vorgangs-Aufwands-Datenfelder werden im Fenster 2 angezeigt.
DFVerteilen2.png

Unsichtbare Felder customizen

target-blue Ziel
  • Im Modul Testmodul sollen dem Datenbereich Vorgang Dauer-Felder hinzugefügt werden, die beim Aufruf des Moduls nicht sichtbar sein sollen, bei Bedarf aber eingeblendet werden können

more Vorgehensweise

  • Den Datenbereich Vorgang aufrufen.
  • Dem Datenbereich neue Dataitems aus der DT463 Vorgang zuordnen:
    • 001131 Dauer-Soll
    • 001132 Dauer-Ist
    • 001133 Dauer-Rest
  • Für die neuen Datenfelder im Feld Fenster den Wert 9 auswählen.
  • Speichern.
DFUnsichtbar.png

more Modul testen

  • Das Modul Testmodul neu starten.
  • Die neuen Dauer-Felder sind im Modul nicht sichtbar.
  • Sie können bei Bedarf eingeblendet werden. Hierzu
    • mit der rechten Maustaste auf die Überschrift der gewünschten Spalte (des Datenfeldes) klicken
    • das Häkchen im Kontextmenü bei der entsprechenden Bezeichnung setzen. Hier werden Häkchen bei allen drei Dauer-Datenfeldern gesetzt.
  • Die neuen Spalten (Datenfelder) werden links von der Spalte eingefügt, von der aus das Kontextmenü aufgerufen wurde
DFUnsichtbar2.png

warning Hinweis

  • Soll es nicht möglich sein, die Datenfelder einzublenden, muss pro Datenfeld die Checkbox DF-Optionen deaktiviert werden.

Alternierende Schattierung customizen

target-blue Ziel

  • Jeder zweite Vorgangs-Datensatz soll farblich hervorgehoben werden.

more Vorgehensweise

  • Den Datenbereich Vorgang aufrufen.
  • Im Parameter Altern. Farbe F1 die Farbe (z.B. 000149), mit der die Vorgangs-Datensätze hervorgehoben werden sollen, hinterlegen oder alternativ eine andere Farbe aus der Listbox auswählen.
  • Im Feld Farbintensität F1 die Intensität der Farbe festlegen.
    • Der Wert wird als Prozentwert (1 - 100 %) angegeben, je höher der Wert, desto dunkler die Farbe.
  • Im Feld Altern. Häufigkeit bestimmen, welche Zeilen in der tabellarischen Darstellung farblich hervorgehoben werden sollen.
    • warning Wird hier kein Wert eingetragen, wird aufgrund der Default-Einstellung jede zweite Zeile hervorgehoben. Wird hingegen z.B. der Wert 3 eingetragen, bedeutet das, dass jede dritte Zeile hervorgehoben wird.
  • Speichern.
SchattierungCU.png

more Modul testen

  • Das Modul Testmodul neu starten.
  • Jeder zweite Vorgangs-Datensatz (da im Feld Altern. Häufigkeit kein Wert eingetragen wurde) wird nun hellgrau hervorgehoben.
SchattierungCU1.png

Einfügen von Datensätzen im Modul ermöglichen

target-blue Ziel

  • Im Modul Testmodul für die Datenbereiche Projekt und Vorgang das Einfügen ermöglichen.

more Vorgehensweise

  • Im Modul Module folgende Parameter in den Datenbereichen Projekt und Vorgang setzen:
  • Das Kontextmenü Einfügen wird automatisch generiert und setzt sich aus zwei Teilen zusammen:
    • dem festen Eintrag Einfügen und
    • der Tabellenbezeichnung (entscheidend ist dabei, aus welcher Datentabelle das DDI stammt) des Datenbereichs bzw. der Datenbereiche; der zweite Teil kann evtl. zwei Abschnitte enthalten:
      • Der erste Abschnitt ist unabhängig davon, auf welchem Datenbereich das Kontextmenü geöffnet wird, immer gleich. In ihm wird/werden immer der oder die Datenbereich/e der obersten Ebene angezeigt, für die das Einfügen erlaubt ist.
    • Ob der zweite Abschnitt erscheint und welche Bereiche darin angezeigt werden, hängt davon ab, ob der fokussierte Datenbereich und/oder seine untergeordneten Bereiche eingefügt werden können.
        • warningDer Text, der im zweiten Teil des Kontextmenü angezeigt wird (Tabellenbezeichnungen) kann durch einen Eintrag im Datenfeld Kontextmenü-Text im Modul Datenbereiche verändert werden.
  • Speichern.
DSEinfuegen.png

application Beispiel für das Kontextmenü

  • Für den Datenbereich Projekt (das DDI stammt aus der DT461 Projekt und der Datenbereich enthält einen Unterbereich Vorgang, bei dem die Parameter Einfügen und Anlegen aktiviert sind) sieht das Kontextmenü dann folgendermaßen aus: Einfügen --> Projekt und Einfügen --> Vorgang.
DSEinfuegen1.png

Modul zu Arbeitsgebiet zuordnen

target-blue Ziel

  • Das Modul Testmodul soll einem Arbeitsgebiet zugeordnet werden.

info Information

  • Gemäß der PLANTA Project-Rechte-Steuerung werden Module einem Benutzer nicht direkt zugeordnet. Diese Zuordnung erfolgt mittels der Zuordnung eines Moduls zu einem Arbeitsgebiet, das anschließend einer Rolle und diese wiederum einem Benutzer zugeordnet wird.

more Vorgehensweise

  • Im Modul Module Rechtsklick --> Modul einem Arbeitsgebiet zuordnen auswählen.
  • Es öffnet sich das Modul Arbeitsgebiet zuordnen.
    • Im Modul Arbeitsgebiet zuordnen das gewünschte Arbeitsgebiet (hier: 01100061 Projektmanagement) aus der Listbox auf dem Feld Arbeitsgebiet auswählen.
    • Speichern.
MODAGZuordnen.png

warning Hinweis

  • Im Modul Module kann man im Feld Anzahl Arbeitsgebiete sehen, wie vielen Arbeitsgebieten das Modul bereits zugeordnet wurde. Auf diesem Feld ist eine Ampel hinterlegt, die signalisiert, ob das Modul bereits einem Arbeitsgebiet zugeordnet wurde (grün), oder noch nicht zugeordnet wurde (rot).
    • Durch Klick auf den Link im Feld oder durch Auswahl der Modulvariante Verwendung wird in die gleichnamige Modulvariante gewechselt. Dort werden die Arbeitsgebiete und Rollen angezeigt, denen das Modul zugeordnet ist.

more Zuordnung testen

  • Anmelden mit dem Benutzer, dem das gewünschte Arbeitsgebiet über eine Rollenzuordnung zugeordnet ist (hier: R8).
  • Das Modul Testmodul ist im Benutzermenü im gewünschten Arbeitsgebiet sichtbar und kann aufgerufen werden.
MODAGZuordnen1.png

Untermodul zu Panel zuordnen

target-blue Ziel

  • Dem Panel, in dem das Modul Testmodul das Hauptmodul ist, ein weiteres Modul als Untermodul zuordnen.

more Vorgehensweise

  • Im Modul Module über die rechte Maustaste Einfügen --> Untermodul einen Datensatz für ein Untermodul einfügen.
  • Im Feld SUBMOD die ID des Moduls eingeben, das als Untermodul in das Panel eingefügt werden soll, z.B. das Modul 0099G2 Projekte.
  • In das Feld Kenner wird automatisch der Wert 1 eingetragen.
  • Speichern.
UntermodulZuordnen.png

more Zuordnung testen

  • Anmelden mit dem Benutzer, der den Zugriff auf das Modul Testmodul (hier: R8).
  • Das Modul Testmodul aufrufen.
  • Das Panel mit dem Hauptmodul Testmodul und dem Untermodul Projekte wird aufgerufen.
UntermodulZuordnen1.png

index Siehe auch: Panel, Customizing von Panels

Exkurs: Löschen

Löschen einer Datenbereichszuordnung

more Vorgehensweise

  • Das Modul Module aufrufen.
  • Im Datenfeld MOD die Modulidentnummer des zu bearbeitenden Moduls eintragen.
  • Mit STRG + Klick den gewünschten Datenbereich markieren.
  • Den Button Löschen in der Symbolleiste betätigen oder den Menüpunkt Bearbeiten --> Löschen auswählen.
    • Es wird nur die Datenbereichszuordnung gelöscht, der Datenbereich selbst bleibt bestehen. Ist er keinem weiteren Modul zugeordnet, wird er im Modul Datenbereiche ohne Zuordnungen angezeigt und kann entweder dort oder direkt im Modul Datenbereiche gelöscht werden.

warning Hinweise

  • Vor dem Löschen einer Datenbereichszuordnung muss überprüft werden, ob die Position des Datenbereichs als Oberbereich für einen oder mehrere nachfolgende(n) Datenbereich(e) eingetragen ist.
  • Nach dem Löschen einer Datenbereichszuordnung sollten die Datenfelder Pos. und Oberbereich entsprechend neu angepasst werden.

Löschen eines Datenbereichs

more Vorgehensweise
  • Im Datenfeld MOD die Modulidentnummer des zu bearbeitenden Moduls eintragen.
  • Den zu löschenden Datenbereich aufrufen.
  • Mit STRG + Klick den Datenbereich markieren.
  • Den Button Löschen in der Symbolleiste betätigen oder den Menüpunkt Bearbeiten --> Löschen auswählen.
  • Der Datenbereich und all seine Zuordnungen zu Modulen werden gelöscht.

warning Hinweise

  • Vor dem Löschen eines Datenbereichs muss überprüft werden, ob die Position des Datenbereichs als Oberbereich für einen oder mehrere nachfolgende(n) Datenbereich(e) eingetragen ist.
  • Nach dem Löschen eines Datenbereichs sollten die Datenfelder Pos. und Oberbereich entsprechend neu angepasst werden.

Löschen eines Moduls

more Vorgehensweise

  • Im Datenfeld MOD die Modulidentnummer des zu löschenden Moduls eintragen.
  • Das Modul mit STRG + Klick auf den Titel des Moduls markieren.
  • Den Button Löschen in der Symbolleiste betätigen oder den Menüpunkt Bearbeiten --> Löschen auswählen.
    • Das Modul und seine Zuordnungen (Datenbereichs- und Untermodulzuordnungen) werden gelöscht.
    • Die Datenbereiche und Untermodule selbst bleiben bestehen.

Zum Modul-Workflow: Level 2 ==>

info Information
  • Im Modul-Workflow: Level 2 werden weitere Customizing-Möglichkeiten erläutert, wie z.B.
    • Customizing von Balkenplan und -funktionen
    • Einbinden der Datumslistboxen mit der CalenderControl-Funktion
    • AOBs customizen
    • etc.
Topic attachments
I Attachment Action Size Date Who Comment
pngpng Ampel.png manage 19.1 K 2011-06-27 - 11:35 UnknownUser  
pngpng Ampel1.png manage 5.8 K 2011-06-27 - 11:38 UnknownUser  
pngpng AmpelCode.png manage 8.5 K 2011-06-19 - 16:34 IrinaZieger  
pngpng BaumdarstellungAnzeigen.png manage 12.3 K 2011-06-29 - 10:14 UnknownUser  
pngpng BaumdarstellungAnzeigen1.png manage 17.0 K 2011-06-29 - 10:07 UnknownUser  
pngpng BaumdarstellungAnzeigen2.png manage 10.0 K 2011-06-28 - 09:47 UnknownUser  
pngpng Checkbox.png manage 18.9 K 2011-06-27 - 11:24 UnknownUser  
pngpng Checkbox1.png manage 7.1 K 2011-06-27 - 11:28 UnknownUser  
pngpng Customizer.png manage 22.5 K 2011-09-14 - 10:01 UnknownUser  
pngpng DBAnlegen1.png manage 20.4 K 2011-06-30 - 10:12 UnknownUser  
pngpng DBAnlegen2.png manage 36.3 K 2011-06-10 - 13:09 UnknownUser  
pngpng DBBearbeiten1.png manage 10.4 K 2011-06-27 - 13:03 UnknownUser  
pngpng DBBearbeiten2.png manage 8.1 K 2011-06-10 - 13:34 UnknownUser  
pngpng DBBearbeiten3.png manage 13.5 K 2011-06-17 - 12:17 UnknownUser  
pngpng DBBearbeiten4.png manage 8.3 K 2011-06-17 - 12:08 UnknownUser  
pngpng DBNeu.png manage 14.3 K 2011-06-15 - 22:36 UnknownUser  
pngpng DBNeu1.png manage 10.0 K 2011-06-29 - 11:52 UnknownUser  
pngpng DBStrukturieren.png manage 8.9 K 2011-06-15 - 23:09 UnknownUser  
pngpng DBStrukturieren1.png manage 11.4 K 2011-06-29 - 10:00 UnknownUser  
pngpng DBZuordnen.png manage 10.0 K 2011-06-30 - 10:18 UnknownUser  
pngpng DFIndividuell.png manage 13.5 K 2011-06-27 - 13:26 UnknownUser  
pngpng DFIndividuell1.png manage 8.0 K 2011-06-27 - 13:29 UnknownUser  
pngpng DFUnsichtbar.png manage 17.8 K 2011-06-16 - 10:06 UnknownUser  
pngpng DFUnsichtbar1.png manage 12.6 K 2011-06-28 - 10:31 UnknownUser  
pngpng DFUnsichtbar2.png manage 11.3 K 2011-06-29 - 13:25 UnknownUser  
pngpng DFVerteilen.png manage 17.3 K 2011-06-28 - 10:07 UnknownUser  
pngpng DFVerteilen1.png manage 13.9 K 2011-06-16 - 09:54 UnknownUser  
pngpng DFVerteilen2.png manage 10.6 K 2011-06-28 - 10:28 UnknownUser  
pngpng DFZuordnen.png manage 15.7 K 2011-06-27 - 13:21 UnknownUser  
pngpng DSEinfuegen.png manage 6.5 K 2011-06-28 - 10:44 UnknownUser  
pngpng DSEinfuegen1.png manage 11.5 K 2011-06-28 - 10:55 UnknownUser  
pngpng LBZuordnenErgebnis.png manage 7.1 K 2011-06-27 - 11:55 UnknownUser  
pngpng LinkDefinieren.png manage 13.9 K 2011-06-29 - 11:25 UnknownUser  
pngpng LinkDefinieren1.png manage 14.5 K 2011-06-29 - 11:10 UnknownUser  
pngpng LinkDefinieren2.png manage 11.8 K 2011-06-29 - 11:19 UnknownUser  
pngpng LinkDefinieren3.png manage 287.8 K 2011-06-27 - 12:47 UnknownUser  
pngpng LinkDefinieren4.png manage 59.4 K 2011-06-27 - 12:56 UnknownUser  
pngpng ListboxZuordnen.png manage 14.9 K 2011-06-27 - 11:52 UnknownUser  
pngpng MODAGZuordnen.png manage 11.3 K 2011-06-30 - 09:51 UnknownUser  
pngpng MODAGZuordnen1.png manage 15.5 K 2011-06-16 - 10:27 UnknownUser  
pngpng MakroBearbeitung.png manage 1.2 K 2011-06-10 - 11:50 UnknownUser  
pngpng MaskeGestalten1.png manage 10.4 K 2011-06-27 - 10:12 UnknownUser  
pngpng MaskeGestalten2.png manage 4.1 K 2011-06-27 - 10:47 UnknownUser  
pngpng MaskeGestalten3.png manage 4.5 K 2011-06-27 - 10:54 UnknownUser  
pngpng MaskeGestalten4.png manage 15.8 K 2011-06-27 - 11:06 UnknownUser  
pngpng ModulAnlegen.png manage 6.4 K 2011-06-10 - 09:24 UnknownUser  
pngpng ModulStarten.png manage 0.8 K 2011-06-10 - 11:19 UnknownUser  
pngpng MussFeld.png manage 18.8 K 2011-06-28 - 11:07 UnknownUser  
pngpng MussFeld1.png manage 6.8 K 2011-06-29 - 09:50 UnknownUser  
pngpng MussFeld2.png manage 3.5 K 2011-06-28 - 12:51 UnknownUser  
pngpng MussFeld3.png manage 8.0 K 2011-06-29 - 09:37 UnknownUser  
pngpng MussFeld4.png manage 6.5 K 2011-06-29 - 09:45 UnknownUser  
pngpng OLEEinbinden.png manage 17.6 K 2011-06-28 - 09:10 UnknownUser  
pngpng OLEEinbinden1.png manage 7.1 K 2011-06-28 - 09:15 UnknownUser  
pngpng PythonMakro.png manage 1.1 K 2011-06-10 - 11:36 UnknownUser  
pngpng RahmenCU.png manage 17.9 K 2011-06-27 - 10:39 UnknownUser  
pngpng RahmenCU1.png manage 9.1 K 2011-06-27 - 10:42 UnknownUser  
pngpng SFEinfuegen.png manage 21.6 K 2011-06-27 - 12:10 UnknownUser  
pngpng SFEinfuegen1.png manage 23.2 K 2011-06-27 - 12:26 UnknownUser  
pngpng SFEinfuegen2.png manage 7.0 K 2011-06-27 - 12:29 UnknownUser  
pngpng SchattierungCU.png manage 13.2 K 2011-06-16 - 10:04 UnknownUser  
pngpng SchattierungCU1.png manage 12.7 K 2011-06-28 - 10:37 UnknownUser  
pngpng Testmodul.png manage 5.1 K 2011-06-10 - 13:21 UnknownUser  
pngpng UntermodulZuordnen.png manage 13.6 K 2011-06-29 - 10:33 UnknownUser  
pngpng UntermodulZuordnen1.png manage 30.7 K 2011-07-04 - 09:41 UnknownUser  
Topic revision: r323 - 2019-07-08 - 14:51:56 - MareikeRichers
Release394.ModulWorkflowLevel1Tutorial moved from Release394.ModulWorkflowLevel1 on 2011-08-03 - 08:07 by IrinaZieger








 
  • Suche in Topic-Namen

  • Suche in Topic-Inhalten