Export nach Excel

target-blue Ziel

  • Exportieren eines Moduls oder bestimmter Bereiche eines Moduls nach Excel
more Vorgehensweise
  • Das gewünschte Modul aufrufen.
  • Den Menüpunkt Extras --> Daten senden an --> Microsoft Excel auswählen.
  • Es öffnet sich das Export-Fenster, in dem die Exporteigenschaften definiert werden können.
    • Falls man die Exportdatei an einer bestimmten Stelle ablegen möchte, den rechteckigen Button im Bereich Speichern unter betätigen und einen gültigen Pfad zum Speichern auswählen.
    • Die Beschreibung der Checkbox Excel-Funktion "Teilung" für Fenster 1 aktivieren finden Sie hier.
    • Es kann zwischen zwei verschiedenen Exportarten gewählt werden.
      • Standardexport:
        • Über die Erweitert -Dialogmeldung kann durch Aktivieren der Checkboxen bei den entsprechenden Datenbereichen bestimmt werden, welche Datenbereiche exportiert werden sollen.
        • Über das Aktivieren der Checkbox Layout exportieren wird bestimmt, ob das Modul-Layout (Farben) in die Excel-Datei übernommen wird.
      • Bulk-Export:
        • warning Ziel des Bulk-Exports ist es, einen Datenbereich mit vielen Daten möglichst schnell nach Excel zu exportieren.
          • OLEs und Farben werden daher aus Performance-Gründen nicht mitexportiert.
        • Im Bereich Datenbereich den gewünschten Datenbereich aus der Listbox auswählen.
          • In dieser Listbox werden alle Datenbereiche des Moduls angezeigt, die exportiert werden können.
          • Defaultmäßig ist der Datenbereich ausgewählt, der die meisten Daten enthält.
    • Durch Betätigen des Buttons Exportieren wird der Exportvorgang ausgelöst.

warning Hinweise

  • Datenbereiche sind nicht exportierbar, wenn in den entsprechenden Datenbereichen
    • keine Datensätze vorhanden sind oder
    • nur Datenfelder mit DF-Verhalten c* (Buttons) oder ba (Balken) vorhanden sind.

Export-Details

Generelles

Ab C 39.5.0

Export-Objekt Export-Besonderheit
Sichtbare/unsichtbare Felder Nur Felder der sichtbaren Fenster 1, 2, 3 werden exportiert. Unsichtbare (ausgeblendete) Felder werden nicht exportiert.
Felder in Tabellen (Spalten) Es wird spaltenweise exportiert. D.h., bei Modulen mit mehreren Datenbereichen wird jeweils das erste Feld der Datenbereiche aus PLANTA-Modulen in die erste Spalte in Excel, jeweils das zweite Feld in die zweite Spalte in Excel usw. exportiert. Diese Zählung gilt pro Fenster und fängt in jedem Fenster von vorn an. Daher werden Felder aus unterschiedlichen Datenbereichen, die in PLANTA-Moudulen eine Spalte bilden, in Excel nur dann in einer Spalte angezeigt, wenn die Anzahl der Felder vor diesen Feldern in den Datenbereichen in PLANTA-Modulen übereinstimmt.
Felder in Masken Felder aus Datenbereichen, die in PLANTA-Modulen als Maske gecustomized sind, werden in Excel nebeneinander dargestellt und zwar in der Reihenfolge der Datenfelder im Datenbereich (nicht zwingend so, wie sie in der Maske an der Oberfläche zu sehen sind).
  • warning Hinweis: Beim Erstellen eines Datenbereichs ist auf die sinnvolle Reihenfolge der Datenfelder zu achten.
  • Vor dem Export kann die Reihenfolge in der Maske mit dem Tabulator überprüft, und wenn nötig, im Datenbereich(Customizing-Modus) durch Verschieben der Datenfelder korrigiert werden.
Mehrere Fenster Beim Export nach Excel wird die Excel-Funktion Teilung für die Darstellung der Trennlinie zwischen dem ersten und zweiten PLANTA Project-Fenster verwendet.
NEU Die Trennlinie zwischen dem zweiten und dritten Fenster in PLANTA Project wird in Excel durch eine (Rahmen-)Linie dargestellt.
  • Aufgrund dessen ist in Excel der Teil, der dem ersten Fenster in PLANTA Project entspricht, fest, und der Teil, der dem zweiten bzw. dritten Fenster in PLANTA Project entspricht, kann gescrollt werden.
    • Durch Deaktivieren der Checkbox Excel-Funktion "Teilung" für Fenster 1 aktivieren wird die entsprechende Funktion ausgeschaltet.note Tipp: Dies wird vor allem in Modulen, in denen das erste Fenster viele Felder enthält, empfohlen, da sonst u.U. nicht alle Felder des Moduls in Excel eingesehen werden können, weil das Scrollen, wie oben erwähnt, nicht möglich ist.
    • Alternativ kann die Fensterteilung in Excel entfernen werden: Hierzu den Menüpunkt Fenster --> Teilung aufheben betätigen.
Überschriften in Masken Überschriften in Masken werden immer exportiert, unabhängig davon, ob sie sichtbar oder unsichtbar sind, vorausgesetzt die entsprechenden Felder sind sichtbar.
Überschriften in Tabellen (Spaltenüberschriften)/keine Spaltenüberschriften Spaltenüberschriften (Checkbox Überschrift ist aktiviert oder Checkboxen Überschrift und Feste Überschrift sind deaktiviert) werden nur dann exportiert, wenn im entsprechenden Datenbereich Datensätze angezeigt werden. Spaltenüberschriften werden immer als feste Überschriften nach Excel exportiert.
Feste Überschriften in Tabellen (feste Spaltenüberschriften) Feste Spaltenüberschriften (Checkbox Feste Überschrift ist aktiviert) werden immer exportiert, unabhängig davon, ob der entsprechende Datenbereich Einträge enthält oder nicht.
Schaltflächen Schaltflächen werden nicht exportiert.
Balken (Histogramm- und Terminbalken) Balken sowie die zugehörige Skala werden nicht exportiert.
Projektionen Projektionen werden mit der zugehörigen Skala exportiert.
Alternierende Schattierung Die alternierende Schattierung wird nicht exportiert.

Bis C 39.5.0

Export-Objekt Export-Besonderheit
Sichtbare/unsichtbare Felder Nur Felder der sichtbaren Fenster 1, 2, 3 werden exportiert. Ausgeblendete Felder werden nicht exportiert.
Felder in Tabellen (Spalten) Es wird spaltenweise exportiert. Es wird spaltenweise exportiert. D.h., bei Modulen mit mehreren Datenbereichen wird jeweils das erste Feld der Datenbereiche aus PLANTA-Modulen in die erste Spalte in Excel, jeweils das zweite Feld in die zweite Spalte in Excel usw. exportiert. Diese Zählung gilt pro Fenster und fängt in jedem Fenster von vorn an. Felder aus unterschiedlichen Datenbereichen werden daher in Excel nur dann in einer Spalte angezeigt, wenn die Anzahl der Felder vor diesen Feldern in den Datenbereichen in PLANTA-Modulen übereinstimmt.
Felder in Masken Felder aus Datenbereichen, die in PLANTA-Modulen als Maske gecustomized sind, werden in Excel nebeneinander dargestellt und zwar in der Reihenfolge der Datenfelder im Datenbereich (nicht zwingend so, wie sie in der Maske an der Oberfläche zu sehen sind).
  • warning Hinweis: Beim Erstellen eines Datenbereichs ist auf die sinnvolle Reihenfolge der Datenfelder zu achten.
  • Vor dem Export kann die Reihenfolge in der Maske mit dem Tabulator überprüft, und wenn nötig, im Datenbereich(Customizing-Modus) durch Verschieben der datenfelder korrigiert werden.
Mehrere Fenster Beim Export nach Excel wird die Excel-Funktion Teilung für die Darstellung der Trennlinie zwischen dem ersten und zweiten PLANTA Project-Fenster verwendet.
  • Aufgrund dessen ist in Excel der Teil, der dem ersten Fenster in PLANTA Project entspricht, fest, und der Teil, der dem zweiten bzw. dritten Fenster in PLANTA Project entspricht, kann gescrollt werden.
    • Durch Deaktivieren der Checkbox Freeze Window1 wird die entsprechende Funktion ausgeschaltet.note Tipp: Dies wird vor allem in Modulen, in denen das erste Fenster viele Felder enthält, empfohlen, da sonst u.U. nicht alle Felder des Moduls in Excel eingesehen werden können, weil das Scrollen, wie oben erwähnt, nicht möglich ist.
    • Alternativ kann die Fensterteilung in Excel entfernen werden: Hierzu den Menüpunkt Fenster --> Teilung aufheben betätigen.

    • Die Trennlinie zwischen dem zweiten und dritten Fenster in PLANTA Project wird in Excel nicht angezeigt.
Überschriften in Masken Überschriften in Masken werden immer exportiert, unabhängig davon, ob sie sichtbar oder unsichtbar sind, vorausgesetzt die entsprechenden Felder sind sichtbar.
Überschriften in Tabellen (Spaltenüberschriften)/keine Spaltenüberschriften Spaltenüberschriften (Checkbox Überschrift ist aktiviert oder Checkboxen Überschrift und Feste Überschrift sind deaktiviert) werden nur dann exportiert, wenn im entsprechenden Datenbereich Datensätze angezeigt werden. Spaltenüberschriften werden immer als feste Überschriften nach Excel exportiert.
Feste Überschriften in Tabellen (feste Spaltenüberschriften) Feste Spaltenüberschriften (Checkbox Feste Überschrift ist aktiviert) werden immer exportiert, unabhängig davon, ob der entsprechende Datenbereich Einträge enthält oder nicht.
Schaltflächen Schaltflächen werden nicht exportiert.
Alternierende Schattierung Die alternierende Schattierung wird nicht exportiert.

Feldtypen

Ab C 39.5.0

Feldtyp Export-Besonderheit
Background-Felder Background-Felder werden nicht exportiert. Ausnahme: Background-Felder, die ein Bild enthalten.
Checkboxen Checkboxen werden als Werte 1 oder 0 (aktiviert/deaktiviert) nach Excel exportiert.
Prozent-Werte Damit PLANTA-Prozentwerte auch in Excel als Prozentwerte formatiert werden, müssen die Datenfelder in PLANTA ein Format besitzen, bei dem das letzte Zeichen "%" ist.
Währungsfelder Bei Währungsfeldern wird immer der Wert aus der Datenbank nach Excel exportiert:
  • Die Werte der Währungsfelder werden als reine Zahlenwerte in der Datenbank gespeichert, und zwar abhängig von der Systemwährung. D.h., ist die definierte Systemwährung eine andere als die Feldwährung, wird der an der Oberfläche eingetragene Wert beim Speichern in die Datenbank konvertiert. Somit kann die Zahl im entsprechenden Feld an der Oberfläche von der Zahl in der Datenbank abweichen.
  • Beispielfälle FeldDatenbankExcel
    1: Feldwährung=CHF, Systemwährung=CHF, Standardwährung in Excel: € 20,000CHF20,000(CHF)20,000€
    2: Feldwährung=€, Systemwährung=CHF, Standardwährung in Excel: €20,000€25,218(CHF)25,218€
    3: Feldwährung=CHF, Systemwährung=€, Standardwährung in Excel: €20,000CHF15,582(€)15,582€
    4: Feldwährung=€, Systemwährung=CHF, Standardwährung in Excel: CHF20.000€ 25,218(CHF)25,218CHF
  • In PLANTA Project besteht die Möglichkeit, Währungsfelder mit unterschiedlichen Formaten zu belegen. Nach dem Export an Excel werden diese im einheitlichen Standardwährungsformat von Excel angezeigt.

    • Z.B. Formate 12345678.00EUR oder 12345.678,00€ von PLANTA Project werden beide nach dem Export in Excel als Format 12.345.678,00€ dargestellt.
    • warning Die Standardwährung in Excel und das Standardwährungsformat werden durch die Regions- und Sprachoptionen definiert.
  • NEU Es besteht die Möglichkeit mit der IronPython-Funktion ExportToExcelSetCurrencyFormatting() pro zu exportierendes Module zu definieren, in welchem Format die Währungs-Datenfelder nach dem Export in Excel dargestellt werden sollen.
Terminfelder Unabhängig vom Terminformat in PLANTA Project wird in Excel das Standardterminformat angezeigt.
  • Z.B. werden die Formate tt-mm-jjjj und mm.tt.jj nach dem Export nach Excel im Format tt.mm.jjjj dargestellt.
Zahlenfelder Der in einem Zahlenfeld angezeigte Wert in PLANTA Project kann sich durch das Hinterlegen eines Zahlenformats von dem in der Datenbank gespeicherten Wert unterscheiden. Beim Exportieren nach Excel wird der in der Datenbank gespeicherte Wert im Standardzahlenformat von Excel angezeigt.
  • In der Datenbank sind z.B. 80 (Stunden) gespeichert, im Feld werden 10 PT angezeigt. Nach dem Export wird in Excel der Wert 80,00 angezeigt.

Bis C 39.5.0

Feldtyp Export-Besonderheit
Background-Felder Background-Felder werden nicht exportiert. Ausnahme: Background-Felder, die ein Bild enthalten.
Checkboxen Checkboxen werden als Werte 1 oder 0 (aktiviert/deaktiviert) nach Excel exportiert.
Prozent-Werte Damit PLANTA-Prozentwerte auch in Excel als Prozentwerte formatiert werden, müssen die Datenfelder in PLANTA ein Format besitzen, bei dem das letzte Zeichen "%" ist.
Währungsfelder Bei Währungsfeldern wird immer der Wert aus der Datenbank nach Excel exportiert:
  • Die Werte der Währungsfelder werden als reine Zahlenwerte in der Datenbank gespeichert, und zwar abhängig von der Systemwährung. D.h., ist die definierte Systemwährung eine andere als die Feldwährung, wird der an der Oberfläche eingetragene Wert beim Speichern in die Datenbank konvertiert. Somit kann die Zahl im entsprechenden Feld an der Oberfläche von der Zahl in der Datenbank abweichen.
  • Beispielfälle FeldDatenbankExcel
    1: Feldwährung=CHF, Systemwährung=CHF, Standardwährung in Excel: € 20,000CHF20,000(CHF)20,000€
    2: Feldwährung=€, Systemwährung=CHF, Standardwährung in Excel: €20,000€25,218(CHF)25,218€
    3: Feldwährung=CHF, Systemwährung=€, Standardwährung in Excel: €20,000CHF15,582(€)15,582€
    4: Feldwährung=€, Systemwährung=CHF, Standardwährung in Excel: CHF20.000€ 25,218(CHF)25,218CHF
  • In PLANTA Project besteht die Möglichkeit, Währungsfelder mit unterschiedlichen Formaten zu belegen. Nach dem Export an Excel werden diese im einheitlichen Standardwährungsformat von Excel angezeigt.

    • Z.B. Formate 12345678.00EUR oder 12345.678,00€ von PLANTA Project werden beide nach dem Export in Excel als Format 12.345.678,00€ dargestellt.
    • warning Die Standardwährung in Excel und das Standardwährungsformat werden durch die Regions- und Sprachoptionen definiert.
Terminfelder Unabhängig vom Terminformat in PLANTA Project wird in Excel das Standardterminformat angezeigt.
  • Z.B. werden die Formate tt-mm-jjjj und mm.tt.jj nach dem Export nach Excel im Format tt.mm.jjjj dargestellt.
Zahlenfelder Der in einem Zahlenfeld angezeigte Wert in PLANTA Project kann sich durch das Hinterlegen eines Zahlenformats von dem in der Datenbank gespeicherten Wert unterscheiden. Beim Exportieren nach Excel wird der in der Datenbank gespeicherte Wert im Standardzahlenformat von Excel angezeigt.
  • In der Datenbank sind z.B. 80 (Stunden) gespeichert, im Feld werden 10 PT angezeigt. Nach dem Export wird in Excel der Wert 80,00 angezeigt.
Topic revision: r70 - 2017-04-25 - 13:59:36 - JanBeck
PPMS39_DE.ExportFunktion moved from PPMS39_DE.ExportImport on 2009-09-08 - 11:58 by IrinaZieger








 
  • Suche in Topic-Namen

  • Suche in Topic-Inhalten