Tutorial: PLANTA Project-Administration Bis DB 39.5.0

stop Achtung

  • Das nachfolgende Tutorial gilt für die Datenbank-Versionen < DB 39.5.0.
  • Links zu den Beschreibungen weiterer Versionen entnehmen Sie bitte der Tabelle:
>= DB 39.5.14 zum Tutorial
DB 39.5.13 zum Tutorial
DB 39.5.0 - DB 39.5.12 zum Tutorial
< DB 39.5.0 zum Tutorial

Einleitung

target-blue Ziel

  • Anhand des nachfolgenden Workflow können Anwender mit Administrationsrechten erlernen, wie man den Mitarbeitern die Arbeit mit PLANTA-Software ermöglicht.

info Informationen

  • Damit die Mitarbeiter eines Unternehmens mit der PLANTA-Software arbeiten können, müssen sie als Personen, Benutzer, Ressourcen und Stakeholder vom Administrator im Programm angelegt und definiert werden.
  • Zur Erfassung und Verwaltung der Mitarbeiterdaten und -rechte steht im PLANTA-System das Panel Administration zur Verfügung, in dem alle notwendigen Module zusammengefasst sind.
    • Die Zugriffsrechte für diese Module sind im Standard sowohl dem Customizer-Benutzer (P20) als auch dem Projektadministrator (R49) und dem Multiprojektmanager (R41) gegeben.
    • Für die Erfassung der Ressourcendaten werden zusätzlich Multiprojektmanagement-Rechte benötigt. Diese werden im Modul Benutzer im Feld Objektberechtigungs-Bezeichnung vergeben.
    • Die Berechtigungen (Rollen und Rechte) lassen sich in PLANTA Project abhängig von individuellen Unternehmensanforderungen verändern. Hierzu lesen Sie bitte das Topic Rechte-Steuerung.

warning Hinweise

  • Alle Übungen bauen auf den PLANTA-Demodaten auf. Diese müssen zuvor installiert sein.
  • Die verwendeten Screenshots dienen der exemplarischen Darstellung und können vom tatsächlichen Layout im Programm abweichen.

Personen anlegen (R41)

target-blue Aufgabe

  • Der neue Mitarbeiter, Herr Schulze, soll in PLANTA Project als Person erfasst werden, damit er mit dem Programm arbeiten kann.

info Informationen

  • Personen gehören zu den Basiselementen in der PLANTA-Software.

more Vorgehensweise

  • Login mit dem Benutzer R41.
  • Im Benutzermenü unter PM-Administration --> Stammdaten aufklappen.
  • Sind noch keine Personen erfasst und ist das Modul Personen komplett leer,
    • die Schaltfläche Neu (im Schaltflächenbereich unten) oder Einfügen (in der Symbolleiste) betätigen.
    • Dadurch wird ein neuer Personen-Datensatz angelegt, in dem die persönlichen Daten des neuen Mitarbeiters eingetragen werden können.
    • Felder Name, Vorname und Kürzel ausfüllen.
      • warning Die ID der neuen Person wird automatisch generiert, sobald eines der oben genannten Felder gefüllt wurde und in das nächste Feld gesprungen wurde.
    • Speichern.
  • Ergebnis:
PersonAnlegen.png

Personenklassifizierung anlegen

target-blue Aufgaben

  • Herrn Schulze soll ein Benutzername vergeben werden, damit er sich im Programm anmelden kann.
  • Des Weiteren soll Herr Schulze
    • als Stakeholder definiert werden, damit er in Projektteams aufgenommen werden kann und
    • als Ressource festgelegt werden, damit er in Projekte eingeplant werden kann und seine geleisteten Stunden auf die entsprechenden Projekte rückmelden kann.

info Informationen

  • Personenklassifizierungen sind Attribute der Personen.
  • Für jede Person werden in PLANTA drei Personeneigenschaften definiert:
    • Benutzer: wird für die Anmeldung der entsprechenden Person im PLANTA-Programm benötigt
    • Stakeholder: wird für die Zusammenstellung der Projektteams benötigt
    • Personenressource: wird für die Einplanung der entsprechenden Person als Ressource in Projekten benötigt

more Vorgehensweise

  • Im Modul Personen im Datensatz von Herrn Schulze die Schaltfläche Personenklassifizierung anlegen betätigen und speichern.
    • Der Person Herr Schulze werden drei Eigenschaften (Benutzer, Stakeholder und Personenressource) mit dem entsprechenden Kürzel automatisch zugeordnet.
      • Das Kürzel für alle drei Eigenschaften ist dem Personenkürzel gleich.
PersonenklassifizierungAnlegen.png

Eine Person als Ressource definieren

target-blue Aufgabe

  • Beim Anlegen von Klassifizierungen wird für Herrn Schulze zwar ein Ressourcenkürzel vergeben, doch dies ist nicht ausreichend, um ihn als Ressource in die Projekte einzuplanen. Es sind noch weitere Einstellungen notwendig.
  • Herr Schulze soll als Ressource definiert werden.

more Vorgehensweise

  • Im Modul Personen im Personenressourcen-Datensatz von Herrn Schulze den Link auf dem Personenressourcennamen betätigen.
  • Dadurch wechselt man ins Modul Ressourcendatenblatt.
  • Die Kopfdaten der Person werden aus dem Modul Personen in das Modul Ressourcendatenblatt übernommen sowie wird das Feld Ressourcenart mit dem Default-Wert "Interner Mitarbeiter" vorbelegt. Weitere Muss-Felder müssen im Ressourcendatenblatt gefüllt werden, damit die neue Ressource gespeichert werden kann.
    • Default-Kostenstelle
    • Default-Kostenart
    • Start- und Endperiode werden beim Aufruf des Moduls automatisch mit dem Heute-Datum vorbelegt und müssen entsprechend der Definition des Planungshorizonts der Ressource angepasst werden. Hierzu siehe das nachfolgende Kapitel "Ressourcenperioden anlegen, bearbeiten, löschen".
  • Speichern.
RessourceAnlegen.png
  • Weitere Angaben können zu einem späteren Zeitpunkt ergänzt werden.

note Details

  • Durch Klick auf die Schaltfläche Verfügbarkeit anzeigen wechselt man in das Modul Verfügbarkeit, in dem die Verfügbarkeit der Ressource pro Tag definiert wird.

Benutzerdaten definieren (R41)

warning Hinweis
  • Die Benutzerdaten der Personen werden nicht direkt im Modul Personen, sondern im Modul Benutzer definiert und bearbeitet.
    • Hierfür im Benutzer-Datensatz der entsprechenden Person den Link auf dem Benutzernamen betätigen. Dadurch wechselt man in das Modul Benutzer und gelangt direkt zum Datensatz des gewünschten Benutzers.

Benutzerpasswort

warning Hinweis

  • Der neu angelegte Benutzer, Herr Schulze, benötigt für die Anmeldung obligatorisch ein Passwort.
    • Beim Anlegen eines Benutzers wird ein leeres Default-Passwort in der Datenbank gespeichert.
    • Dieses muss bei der Erstanmeldung vom Benutzer sofort in das richtige Passwort umgewandelt werden, nur dann kann sich der Benutzer in das System einloggen.
    • Falls aus Sicherheitsgründen keine leeren Passwörter erwünscht sind, kann der Administrator für jeden neuen Benutzer alternativ ein temporäres Passwort erzeugen, das bei der Erstanmeldung eingegeben wird und ebenfalls sofort vom Benutzer geändert werden muss.

Einem Benutzer Rollen zuordnen

target-blue Aufgabe

  • Herr Schulze soll im Unternehmen X die Rolle des Projektmanagers für das Projekt Y übernehmen.
    • Hierzu muss Herrn Schulze in PLANTA Project die Rolle des Projektmanagers zugeordnet werden.

info Informationen

  • Über die Rollenzuordnung werden einem Benutzer die Zugriffsrechte auf bestimmte Objekte (Module, Menüpunkte, die wiederum in Arbeitsgebiete gruppiert sind) vergeben.
  • Jedem Benutzer müssen mindestens zwei Rollen zugeordnet werden: Die eine regelt den Zugriff auf Menüpunkte und die andere oder die weiteren regeln den Zugriff auf Module.
  • Bei der Programmlieferung werden dem Kunden die von PLANTA definierten Standardrollen zur Verfügung gestellt. Diese können entsprechend den individuellen Unternehmensanforderungen im Modul Rollen geändert oder angepasst werden oder individulelle Rollen können angelegt werden.
  • Weitere Informationen zu Rechte-Steuerung in PLANTA Project.
    • Bitte lesen Sie diese Informationen sorgfältig durch, da die nachfolgenden Ausführungen das Verständnis des PLANTA Rollen- und Rechtekonzepts voraussetzen.

more Vorgehensweise

  • Im Modul Benutzer Klick mit der rechten Maustaste auf den Benutzer-Datensatz von Herrn Schulze und Auswahl Einfügen --> Rolle.
  • Ein Rollen-Datensatz wird eingefügt.
    • Aus der Listbox im Feld Rolle die Rolle des Projektmanagers, im Standard 01100219 Projektmanagement, auswählen und speichern.
RolleZuordnen1.png
  • Einen weiteren Rollen-Datensatz einfügen und eine der Standardrollen für Menüpunkte z.B. 01100192 R39 MP Gesamt aus der Listbox auswählen.
    • warning Die Zuordnung einer Menüpunkt-Rolle ist für jeden Benutzer obligatorisch. Ohne eine solche Rolle kann der Benutzer das Programm nicht starten. Beim Versuch, sich mit einem Benutzer anzumelden, der keinen Zugriff auf Menüpunkte besitzt, erscheint die Meldung: IEmenu_send(): menuitems couldn't be fetched. Closing application. (See log file for further information)
  • Speichern.
RolleZuordnen2.png

  • Nachdem sich Herr Ralf Schulze angemeldet hat, sieht er in seiner Symbolleiste die zugeordneten Menüs mit den entsprechenden Menüpunkten. Die zugeordnete Rolle findet er in seinem Benutzermenü.
RolleZuordnen3.png

warning Hinweis

  • Die Benutzer-Rollen-Zuordnung kann auch im Modul Personen vorgenommen werden, nachdem für eine Person das Attribut Benutzer definiert wurde.
    • Hierzu Rechtsklick auf den Benutzer-Datensatz und Auswahl Einfügen --> Rolle. Weitere Vorgehensweise wie oben beschrieben.

warning Hinweis

  • Falls die PLANTA-Standardrollen Projektmanager und R39 MP Gesamt nicht den Anforderungen des Unternehmens X entsprechen, kann der Benutzer mit Administrationsrechten individuelle Rollen anlegen.

Exkurs: Rollen zusammenstellen

more Vorgehensweise

  • Im Panel Administration ins Modul Rollen wechseln.
    • Da PLANTA bei der Programmlieferung Standardrollen mitliefert, sind diese beim Aufruf des Moduls vorhanden.
  • Klick mit der rechten Maustaste auf eine bereits bestehende Rolle und Auswahl des Befehls Einfügen --> Rolle.
  • Die Bezeichnung für die neue Rolle im Feld Rollenbezeichnung vergeben und speichern.
    • Dadurch wird im Feld Rolle automatisch eine Identnummer generiert.
  • Handelt es sich bei der neuen Rolle um eine Menüpunkt-Rolle, muss bei dieser Rolle die Checkbox Unsichtbar im Benutzermenü aktiviert werden.
  • Der neuen Rolle Arbeitsgebiete zuordnen:
    • Über die rechte Maustaste Einfügen --> Arbeitsgebiet auswählen und das gewünschte Arbeitsgebiet aus der Listbox auswählen.
    • Speichern.
    • warning Zur Auswahl stehen Standardarbeitsgebiete. Falls ein individuelles Arbeitsgebiet zugeordnet werden soll, muss dieses erst im Modul Arbeitsgebiete angelegt und definiert werden.

Exkurs: Arbeitsgebiete zusammenstellen

more Vorgehensweise

  • Das Modul Arbeitsgebiete aufrufen.
    • warning Im Modul Arbeitsgebiete werden ausschließlich neue Arbeitsgebiete für Module angelegt und zusammengestellt. Neue Arbeitsgebiete für Menüpunkte werden im Modul Menüpunkte angelegt. Hierzu siehe auch das Kapitel Zugriff für Menüpunkte einschränken.
  • Es erscheint automatisch ein leerer Arbeitsgebiet-Datensatz.
  • Im Feld Arbeitsgebietsbezeichnung den Namen für das neue Arbeitsgebiet vergeben.
  • Nach Eingabebestätigung wird automatisch eine Nummer im Feld Arbeitsgebiet generiert.
  • Aus der Listbox im Feld Kategoriebezeichnung den Wert GR Modulgruppierung auswählen.
  • Dem Arbeitsgebiet Module zuordnen. Hierfür:
    • Rechtsklick auf den Arbeitsgebiet-Datensatz und Auswahl des Befehls Modul.
      • Der Modul-Datensatz wird eingefügt.
    • Die Nummer des gewünschten Moduls aus der Listbox im Feld MOD auswählen oder manuell eintragen
    • Speichern.
      • Auf dieselbe Weise dem Arbeitsgebiet weitere Module zuordnen.

Zugriff auf Menüpunkte einschränken

target-blue Aufgabe

  • Der Multiprojektmanager des Unternehmens X ist der Meinung, dass Herr Schulze nicht auf alle, sondern nur auf bestimmte Menüpunkte Zugriff bekommen soll und zwar auf die Menüpunkte der Menüs Daten, Ansicht und Bearbeiten. Er möchte den Menüpunkte-Zugriff für Herrn Schulze ändern lassen.

more Vorgehensweise

  • Im Panel Administration das Modul Menüpunkte öffnen.
    • Das Modul enthält zwei PLANTA Standard-Arbeitsgebiete für Menüpunkte. Diese dürfen nicht verändert werden.
    • Um für Herrn Schulze den Zugriff auf Menüpunkte einzuschränken, muss ein individuelles Arbeitsgebiet angelegt und einer individuellen Rolle zugeordnet werden.
  • Das Arbeitsgebiet R39 Gesamt (CU) per Drag&Drop kopieren.
RolleErstellen1.png

  • Dabei wird automatisch ein neues Arbeitsgebiet angelegt und alle Datensätze (in diesem Fall Menüpunkte) aus dem Quell-Arbeitsgebiet in das neue Arbeitsgebiet kopiert.
  • Das neue Arbeitsgebiet benennen, z.B. R390 Restricted access.
RolleErstellen2.png

  • Im neuen Arbeitsgebiet können die Menüpunkte je nach Anforderung entfernt oder ausgeschaltet werden.
    • Es bestehen zwei Möglichkeiten zum Ausschalten von Menüpunkten.
      • Normale Menüpunkte
        • sind fest programmiert und können nicht aus dem Arbeitsgebiet entfernt werden.
          • Um solche Menüpunkte auszuschalten, im Feld Struktur eine 0 eintragen.
      • Menüpunkte zum Aufruf von Makros und Modulen (mit der Nummer 0001 gekennzeichnet),
        • können pro Arbeitsgebiet individuell angelegt und gelöscht oder wie normale Menüpunkte ausgeschaltet werden.
          • Um sie auszuschalten, im Feld Struktur eine 0 eintragen oder die Menüpunkte aus dem Arbeitsgebiet entfernen.
    • Also im Fall von Herrn Schulze für alle Menüpunkte bis auf die in den Menüs Daten, Ansicht und Bearbeiten im Feld Struktur eine 0 eintragen.
RolleErstellen3.png

RolleErstellen4.png

  • Mittels rechter Maustaste Einfügen --> Arbeitsgebiet dieser Rolle das neue Arbeitsgebiet zuordnen.
    • Speichern.
RolleErstellen5.png

  • Ins Modul Benutzer wechseln und dem Benutzer Ralf Schulze die neue Rolle manuell zuordnen.
    • Die Standardmenüpunkt-Rolle R39 MP Gesamt entfernen.
RolleErstellen6.png

  • Nachdem sich Herr Ralf Schulze wieder angemeldet hat, sieht er in seiner Symbolleiste nur die Menüs Daten, Ansicht und Bearbeiten mit den entsprechenden Menüpunkten.
RolleErstellen7.png

warning Hinweis

  • Auf die gleiche Weise kann man auch einzelne Menüpunkte innerhalb von Menüs ausschalten.

Benutzer-Startup definieren (P20)

target-blue Aufgabe

  • Wenn sich Herr Schulze in PLANTA Project anmeldet, soll automatisch das Modul Problemfälle aufgerufen werden.

info Information

  • Hierzu muss dem Benutzer Herr Schulze das entsprechende Startup-Makro zugeordnet werden.

more Vorgehensweise

  • Login mit R41.
  • Im Modul Problemfälle in der Symbolleiste ? --> Modulinformation auswählen.
  • Die Modulnummer, die unterhalb des Kürzels MOD steht, notieren.
  • Login mit P20.
  • Im Modul Globale Einstellungen mittels rechter Maustaste --> Einfügen --> Globale Einstellung eine neue globale Einstellung hinzufügen.
  • Unter Klasse aus der Listbox Modul-ID auswählen.
  • Unter Alpha 120 die vorher notierte Modulnummer des Moduls Problemfälle eintragen.
  • Im Feld Python-ID eine Python-ID eintragen, z.B.
    • L100_startup_module_problemfaelle für das Startup des Moduls Problemfälle

StartupDefinieren1.1.png

warning Hinweise

  • Bei der Lizenznummer L100 handelt es sich lediglich um eine Beispielnummer. Je nach Lizenznummer des Kundens wird diese an dieser Stelle automatisch eingetragen.
  • Speichern.
  • Um ein Startup-Makro zu definieren, im Modul Module ein neues Modul anlegen.
  • Dazu unter Modul eine Bezeichnung eintragen (z.B. Problemfälle aufrufen).
  • Unter Klasse aus der Listbox 6 Makromodul auswählen.
StartupDefinieren5.1.png

  • Über die Schaltfläche StartupDefinieren4.png Makrobearbeitung aufrufen ins Modul Pythonmakros wechseln.
  • Dort auf die Schaltfläche StartupDefinieren8.png Python-Makrobearbeitung aufrufen klicken.
  • Folgendes Makro per Copy/Paste einfügen:

from ppms import ppms_cu

mod_obj=ppms.get_target_module()

module_id=ppms_cu.Helper.get_global_setting("L100_startup_module_problemfaelle").alpha120.get_value()

ppms_cu.Action(mod_obj).call_startup_module(module_id)

  • Ergebnis im Programm:

StartupDefinieren6.1.png

  • Das neue Makro-Modul dem Arbeitsgebiet 01100111Startup-Module zuordnen (rechte Maustaste --> Modul einem Arbeitsgebiet zuordnen), damit das neue Makro-Modul später im Modul Benutzer in der Listbox Startup-Makro-Bezeichnung angezeigt wird.

StartupDefinieren7.1.png

StartupDefinieren3.1.png

  • Nach der Neuanmeldung von Herrn Schulze wird automatisch das Modul Problemfälle aufgerufen.

StartupDefinieren2.1.png

warning Hinweise

  • Bei der oben beschriebenen Vorgehensweise ist das Startup-Modul für den Benutzer fest definiert.
  • Der Administrator kann dem Benutzer ein Startup-Makro zuordnen, das dem Benutzer ermöglicht, selbst zu entscheiden, welche der vom Administrator bereits definierten Startup-Module bei der Anmeldung geladen werden und welche nicht. Mehr dazu siehe hier.
  • Bereits angelegte Startup-Module müssen nicht erneut definiert werden, sondern können direkt im Benutzer-Datensatz im Feld Startup-Makro-Bezeichnung ausgewählt werden.
Topic attachments
I Attachment Action Size Date Who Comment
pngpng PersonAnlegen.png manage 6.9 K 2011-04-08 - 16:40 IrinaZieger  
pngpng PersonenklassifizierungAnlegen.png manage 10.6 K 2011-04-08 - 16:40 IrinaZieger  
pngpng RessourceAnlegen.png manage 71.6 K 2011-04-08 - 16:48 IrinaZieger  
pngpng RolleErstellen1.png manage 7.7 K 2011-04-26 - 22:17 UnknownUser  
pngpng RolleErstellen2.png manage 11.7 K 2011-04-26 - 21:16 UnknownUser  
pngpng RolleErstellen3.png manage 215.5 K 2010-12-01 - 16:56 UnknownUser  
pngpng RolleErstellen4.png manage 5.3 K 2011-04-26 - 21:35 UnknownUser  
pngpng RolleErstellen5.png manage 7.0 K 2011-04-26 - 21:35 UnknownUser  
pngpng RolleErstellen6.png manage 6.5 K 2011-08-10 - 13:08 UnknownUser  
pngpng RolleErstellen7.png manage 22.2 K 2011-08-10 - 13:07 UnknownUser  
pngpng RolleZuordnen1.png manage 5.8 K 2011-08-10 - 12:51 UnknownUser  
pngpng RolleZuordnen2.png manage 6.3 K 2011-08-10 - 12:51 UnknownUser  
pngpng RolleZuordnen3.png manage 23.6 K 2011-08-10 - 12:58 UnknownUser  
pngpng StartupDefinieren1.1.png manage 13.8 K 2011-08-03 - 16:04 JuliaSchwarz  
pngpng StartupDefinieren1.png manage 12.5 K 2011-06-08 - 17:31 JuliaSchwarz  
pngpng StartupDefinieren2.1.png manage 72.1 K 2011-08-03 - 16:32 JuliaSchwarz  
pngpng StartupDefinieren2.1EN.png manage 63.9 K 2011-08-10 - 12:33 UnknownUser  
pngpng StartupDefinieren3.1.png manage 9.5 K 2011-06-09 - 10:08 JuliaSchwarz  
pngpng StartupDefinieren4.png manage 1.3 K 2010-12-01 - 10:02 UnknownUser  
pngpng StartupDefinieren5.1.png manage 6.0 K 2011-06-08 - 17:49 JuliaSchwarz  
pngpng StartupDefinieren5.png manage 6.0 K 2011-06-08 - 17:42 JuliaSchwarz  
pngpng StartupDefinieren6.1.png manage 7.4 K 2011-08-03 - 16:11 JuliaSchwarz  
pngpng StartupDefinieren7.1.png manage 8.4 K 2011-06-09 - 10:09 JuliaSchwarz  
pngpng StartupDefinieren8.png manage 1.1 K 2011-06-09 - 10:09 JuliaSchwarz  
Topic revision: r166 - 2019-09-11 - 17:21:58 - MareikeRichers
Current.BenutzerWorkflowTutorialBisDB3950 moved from Current.BenutzerWorkflowTutorial on 2014-05-15 - 09:46 by HansjoergFuchs - put it back








 
  • Suche in Topic-Namen

  • Suche in Topic-Inhalten